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Summary


During certain troubleshooting situations, Netskope Support may request various debugging output from the Google Chrome Developer Tools (DevTools for short). Specifically, HAR (HTTP Archive) is a file format used by several HTTP session tools to export detailed traffic data for analysis.


Environment


Users experiencing cloud app page loading or performance issues while using a browser. Application access issues Reverse proxy (SAML/Auth).


 


Cause


Netskope Support and Engineering require HAR debug output from the affected client to provide app traffic data for analysis.


Resolution


If requested by Netskope Support, please provide the HAR debug output with the following instructions (please reference the following link for additional details: (https://toolbox.googleapps.com/apps/har_analyzer/) 


Warning


Please be cautious that the HAR capture will have sensitive information like Application login Username, Password etc in clear text. 


After saving the HAR capture following the steps below, open the file using text editor. Search for the sensitive information and remove/mask it before uploading the Support ticket. 


  

 


 


 


 


 


 


Note: The HAR output is available for Chrome, Firefox, and Internet Explorer (IE). For the instructions below, Google Chrome is referenced (the link above provides instructions for other browsers).


1. Open Google Chrome.


2. Enable DevTools.


 


3. Click on the Network tab.


4. Look for a Round Indicator at the top left of the Network tab. Make sure it is Red (default is red). If the indicator is grey, click the round indicator once to start recording.


5. Check the box next to Preserve log.



 


6. Optionally, you can use the clear button (a circle with a diagonal line through it) right before trying to reproduce the issue to clear the app traffic output.


7. Save the capture by right-clicking on the grid and choosing Save as HAR with Content.


 

 


 


Steps to capture HAR in case of a link in the browser page opens up in a new browser tab/pop-up


There is an option in chrome dev tools to capture HAR from the new browser window/pop-up. 
1. Enable Developer Tools on the browser page for which you will be capturing HAR.
2. Click on the three dots on the right upper corner and select Settings.

3. In settings page, enable the Auto-open Dev tools for popups.


4. After selecting this we can close this window and continue traffic capture. When any link on the browser page opens a new window, the dev tools will automatically get enabled on that page and capture HAR.

5. This is a one time setting so it's not required to enable it every time we do this activity. Lastly, upload the HAR output file to the Netskope case that was created to track your issue.








@mherbinet wrote:

Warning

Please be cautious that the HAR capture will have sensitive information like Application login Username, Password etc in clear text. 

After saving the HAR capture following the steps below, open the file using text editor. Search for the sensitive information and remove/mask it before uploading the Support ticket. 

  

 

 

 

 

 

 

This is why I would prefer to see initial troubleshooting request NetLog instead for Chromium based browsers.  The default behavior is to automatically strip an array of "private" details.

 




You can download the HAR file over browser by going to developer tool and navigate over network and the run the url the after you can download the HAR which is in developer tool 


Recently I saw a demo by a Netskope competitor that capture the HAR at the proxy instead of relying on relying on contacting / tracking down end-users.  This is something that Netskope should consider.


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