Solved

Microsoft Azure DevOps issues with to "rproxy.goskope"

  • 10 January 2023
  • 3 replies
  • 264 views

Badge

Hello all,

I am not certain this is the correct group, and I apologize if this is a wrong posting, but I am running out of options and any help or advice would be appreciated. I did some search in internet and I guessed this could be the right support board.

 

An organization for which I am working on a project has recently installed a product which redirects access to MIcrosoft Azure DevOps and inserts ".rproxy.goskope" to the URL, such as below:

BEFORE: https://dev.azure.com
AFTER: https://dev.azure.com.rproxy.goskope.com/


This completely breaks the functionalities of Azure DevOps.

I have reached out to the Microsoft support, and they indicated that this "URL changing" should be causing the problem.

Unfortunately, nobody in the organization I am handling the project with currently knows why this URL change happened and what is the cause for it, so I tried to do some research by myself, which led me to this support page.

If anybody has some ideas what is happening, or could direct me to a better support, this would be very much appreciated. And again, apologies if this is a wrong post.

Thanks,
Werner




icon

Best answer by MM_NS 10 January 2023, 17:48

View original

3 replies

Badge +14

Changing of the URL is expected behavior with the introduction of Netskope's reverse proxy; however there is a select set cloud applications are supported with this Netskope deployment option. I would suggest having the Netskope admins in this organization you are working for, engage Netskope support or the professional services group that is deploying Netskope for assistance with Netskope's reverse proxy.  

Userlevel 3
Badge +13

Hi Werner.

 

If reverse proxy is no longer a use case for your org, you can delete the appropriate Reverse Proxy configuration that should be  here. (Typically third column Application would be "Reverse Proxy as a Service")

 

https://< your tenant>.goskope.com/ns#/settings?view=samlReverseProxy

 

Please also contact your Azure AD admin. There should be a corresponding Netskope App on Azure AD that must have been added as part of enabling reverse proxy.

 

Badge

Hello,
it was the problem in the Azure AD configuration, the admin fixed it now.
Thanks for help,

Werner

Reply