Traffic Steer on Galaxy S8

Badge +5

Hello folks,

I'm having difficulties to use traffic steering on my Galaxy S8.

Hopefully, I want to know what caused this and if it is what it is, way to configure my Galaxy S8/Android device to use VPN like iOS would be nice.


I've sent invitation to my email account on Security Cloud Platform -> Netskope Client -> Users.

Then clicking Android Client link on the mail led me to Google Play Store link. Then Google Play Store Netskope Cloud Directory page appears and I tab install button. Then open. Then Netskope Client says "Client is waiting for configuration". Then nothing. No further progress.

In Settings, Organization, Gateway, Gateway IP Address, Steering Configuration, Device Classification are blank.


My other Galaxy Note 10 appears to working fine.


both devices gets link like

(I changed some characters in case)



If I could find a way to steer Galaxy S8 traffic to Netskope by itself like using VPN configuration, it would be nice.


Anyone bright on this?


I appreciate your time,



Best answer by hyunbo 24 April 2022, 12:30

View original

7 replies

Badge +6

Thank you for reaching out, @hyunbo! Our community team is looking for a solution for you and will get back with you shortly! If any community members know a solution, please feel free to respond in this thread.

Badge +14

@hyunbo did you use the same email message to install the client?  Client install from email is one-time use - so if you sent email to yourself and installed it on one device, and then tried to do the same email and install on another device, client enrollment will fail on the second device.  If you are doing install from two unique email invites, then would be good to email client error log from S8 device to Netskope support and they will troubleshoot it for you

Badge +5

Hi @mkoyfman .

I used unique invitation for each devices. I had looped enrolling steps several times past two months.

I'll send the logs to Netskope support. I'm attaching the same log here for your reference in case. The log is from 4th April to 8th April (today, KST) which acquired from Netskope Client on my Galaxy S8.

Thank you for the suggestion!

Badge +11

Hello @hyunbo 

First, please double check app restrictions on your android device.
nsdebuglog.log shows many errors related to this.

Also user email is blank, which can happen when you manually download cloud director prior to click email tokenized link.

In addition, did you create a separate steering profile for android devices ?

You need to create a user group (via SCIM or AD Importer), with your android user in it, bind this group to a dedicated CASB-only profile and finnaly specific which cloud app you want to steer. In my testing, I could not use default steering profile and had the same blank page behavior.
Another reason could be communication issue to Netskope Cloud or failure to retrieve 

Badge +5

FYI, I reached out to Netskope support and got a workaround.


Rajesh M said Netskope Client should be in "protected mode" which I don't know what it is and how to do it. I provided two possibilities those could be related to "protected mode" I attached as screen shot here. Communication about "protected mode" ended here. He mentioned nsclient should be running in background to receive configs from the Playstore but some devices block it.

Besides "protected mode" I correctly performed required actions from the first place.


Rajesh M suggested to try Chrome OS setting link which consisted of like "intent://nsclientconfig/#Intent,scheme=ncc;package=com.netskope.netskopeclient;;S.tid=garbled;S.ukey=targled;S.activationKey=garbled;end" and it worked like charm.

You can add ChromeOS link at invitation email template edit page.


What I did :

1. Leave not working Netskope Client as it is.

2. Click the link on "Step 2" of Chrome OS link in modified email invitation.

3. Voila!


I hope this helps someone and I appreciate to you who paid attention.

Have a wonderful day.



Badge +5

Hello @mherbinet 

Thank you for your reply.

I have only able to found two entities about app restrictions which was "Device admin apps" and "Permissions" - "Storage" which I attached to my own last reply.

I've never downloaded/installed Netskope Cloud Director(Netskope Client) only used tokenized link.

No I did not created separate steering, I'm using default steering for all my Windows, MacOS, Android devices.

I'm happy with the workaround Rajesh M provided to me for now, so I will try add another steering option you mentioned when I confront similar situation, although I'm not sure what you mean by "CASB-only profile".

Have a nice day.

Badge +5

@hyunbo wrote:


I've never downloaded/installed Netskope Cloud Director(Netskope Client) only used tokenized link.

-> I've never downloaded/installed Netskope Cloud Director(Netskope Client) manually. I only used tokenized link.