Cloud Exchange Docker containers failing to start upon reboot

  • 11 April 2022
  • 6 replies

  • Anonymous
  • 0 replies

I am running into a repeatable issue with mongodb and rabbitmq not starting upon reboot.  



  • Fresh install of Cloud Exchange 3.2 on Ubuntu 20.04.4 LTS
    • Docker installed from the Ubuntu installation options during OS installation
    • Installed into /home/{user}/netskope/ta_cloud_exchange
  • Upon initial ./start all containers start normally.
  • After server reboot, rabbitmq and mongodb fail to start
  • running docker-compose up will start them successfully, but get a bad gateway when attempting to login to the GUI
    • The custom_plugins directory is set to 755


Is anyone else seeing this issue, or have any recommendations? 


Best answer by Anonymous 24 June 2022, 15:25

View original

6 replies

It looks like if I run sudo docker-compose start after boot, the remaining containers that didn't auto-start will spin up.  I am not seeing anything in the docker-compose.yml file that stands out that wouldn't start specific containers.  

Badge +11



Did you change the mongo db permissions before running docker compose ?
We also got report that some zip install were getting corrupted while downloaded via Chrome.

Try to download install file from Firefox instead.

By the way, Cloud Exchange 3.3 in now GA. You may want to give it a try.



The permissions are correct on the mongo repository.  These permissions were not changed, as I followed the instructions on github, with cloning the repo via git (not downloading with a browser), and running ./setup & ./start, which run provided scripts by Netskope.  The only reason I ran docker-compose was due to the issue with RabbitMQ starting after reboot. 

Working with someone at Netskope last week, they verified this is an issue and he put a ticket in to get this resolved.  Also moving to 3.3 doesn't resolve the issue.  

Userlevel 2
Badge +15

 docker is set to start at boot? 

sudo systemctl enable docker


@ryans this was a known issue with the .yaml file settings, and has been resolved in 3.3.1 release.


Confirmed issue is resolved after reboot of Docker host. 

Badge +3

Hi, Im having the same issue. Just installed All the required docker components, git and python, but when starting Netskope using ./start, the UI displays Bad Gateway error. I followed the instruction from here and from

 but everytime after running ./setup, I checked the ta_cloud_exchange dir all permissions resets back to 999.

ANy ideas?

Thanks WS