Solved

Cloud Exchange Bad Gateway error


Badge +3

Hi Im having similar issues as others are when launching CE UI portal.

https://community.netskope.com/t5/Additional-Discussions/Cloud-Exchange-not-staying-up-Bad-Gateway/m-p/2139

I ran the ./setup but no luck. Changed the UID and GUID of the following folders to 1001 and ran the ./setup, but it keeps reverting back to 999

https://community.netskope.com/t5/Additional-Discussions/Cloud-Exchange-Docker-containers-failing-to-start-upon-reboot/m-p/1271

 

Any ideas please?

THanks Winder,

 

icon

Best answer by WinderS 12 July 2023, 01:06

View original

4 replies

Userlevel 3
Badge +15

99% of the time that people get the bad gateway error comes down to the Maintenance Password. Is this a new install? 
In new installs I have seen customers include special characters causing this problem. 

In upgrades or reinstalling Cloud Exchange I have seen customers give a different password than they used the first time installing CE. 

 

Reach out to me if you need help. gjenkins@netskope.com 

Badge +3

Hi Gary,

Thanks for your reply.

Yes this is a new install and there is no special characters included in the maintenance passwd. I have 2 servers built and documented the steps including the jwt token and maintenance passwd which is purely a 19 char sentence with all lowercase (would not accept more than 20 char)

I received a snipit of a support call by other customers from our local Netskope SE where they applied the following – which apparently fixed it.

  • chown 999:999 -R data/database-init
  • chmod 664 data/database-init/mongo-init.sh

and ran ./setup script.

I have tried that, but setup resets it back to default value.

 Happy to share my installation steps with you.

Any assistance will be greatly appreciated!

Cheers

WinderS

Badge +3

Hi Gary, Thanks for the suggestion. As suggested, I deleted the ta dir and re-pulled the git and followed the bouncing ball from here: https://community.netskope.com/t5/Blogs/A-Guide-to-Deploy-Netskope-Cloud-Exchange/ba-p/1143

Manage to login successfully. Will not carry out the necessary setup by adding the tenant and plugins.

Thanks once again for your assistance.

Highly appreciate it

Cheers

Winder,

Badge +3

It should have read " Will now carry out the necessary setup...." My bad. 😄

 

Reply