cancel
Showing results for 
Search instead for 
Did you mean: 

Cloud Exchange Docker containers failing to start upon reboot

mattfrank
New Contributor II

I am running into a repeatable issue with mongodb and rabbitmq not starting upon reboot.  

 

Details

  • Fresh install of Cloud Exchange 3.2 on Ubuntu 20.04.4 LTS
    • Docker installed from the Ubuntu installation options during OS installation
    • Installed into /home/{user}/netskope/ta_cloud_exchange
  • Upon initial ./start all containers start normally.
  • After server reboot, rabbitmq and mongodb fail to start
  • running docker-compose up will start them successfully, but get a bad gateway when attempting to login to the GUI
    • The custom_plugins directory is set to 755

 

Is anyone else seeing this issue, or have any recommendations? 

1 ACCEPTED SOLUTION
mattfrank
New Contributor II

@ryans this was a known issue with the .yaml file settings, and has been resolved in 3.3.1 release.  https://github.com/netskopeoss/ta_cloud_exchange/commit/72ba556d42d5ab35c485de0402a2d46129133c64

 

Confirmed issue is resolved after reboot of Docker host. 

View solution in original post

5 REPLIES 5
mattfrank
New Contributor II

It looks like if I run sudo docker-compose start after boot, the remaining containers that didn't auto-start will spin up.  I am not seeing anything in the docker-compose.yml file that stands out that wouldn't start specific containers.  

mherbinet
Moderator
Moderator

Hello,

 

Did you change the mongo db permissions before running docker compose ?
We also got report that some zip install were getting corrupted while downloaded via Chrome.

Try to download install file from Firefox instead.

By the way, Cloud Exchange 3.3 in now GA. You may want to give it a try.

 

 

mattfrank
New Contributor II

The permissions are correct on the mongo repository.  These permissions were not changed, as I followed the instructions on github, with cloning the repo via git (not downloading with a browser), and running ./setup & ./start, which run provided scripts by Netskope.  The only reason I ran docker-compose was due to the issue with RabbitMQ starting after reboot. 

Working with someone at Netskope last week, they verified this is an issue and he put a ticket in to get this resolved.  Also moving to 3.3 doesn't resolve the issue.  

ryans
Netskope
Netskope

@mattfrank docker is set to start at boot? 

sudo systemctl enable docker

 

mattfrank
New Contributor II

@ryans this was a known issue with the .yaml file settings, and has been resolved in 3.3.1 release.  https://github.com/netskopeoss/ta_cloud_exchange/commit/72ba556d42d5ab35c485de0402a2d46129133c64

 

Confirmed issue is resolved after reboot of Docker host.